This article was collected and archived by Digital Sovereignty Watch from an institutional or public source relevant to digital sovereignty, technology policy, cybersecurity, cloud services, artificial intelligence or European regulation.
Cybersecurity
Critical vulnerability in GitLab software (CVE-2026-97229)
The updates published by GitLab address this vulnerability if the instance uses GitLab’s official Ruby package (the security flaw lies in Ruby’s regular expression processing). If the patched GitLab Ruby package is not used—for example, if Ruby is run from source or in another way—Ruby must be updated to version 3.3.13, 3.4.12, 4.0.9, or later; otherwise, the vulnerability remains unaddressed. More information: https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves/ GitLab has released updates addressing a critical integer overflow vulnerability, CVE-2026-97229, in GitLab Community Edition (CE) and Enterprise Edition (EE) software. Due to insufficient regular expression validation, an unauthenticated user could exploit this vulnerability to execute arbitrary code on the GitLab server by using a specially crafted regular expression in a CI/CD configuration. Required action: Immediately update GitLab instances to one of the fixed versions: 19.4.2, 19.3.5, or 19.2.8. More information: https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released